Download algorithme exercices corrigés PDF

Titlealgorithme exercices corrigés
File Size6.8 MB
Total Pages73
Document Text Contents
Page 2

Exercice 1

• Quelles seront les valeurs des variables A et B après exécution
des instructions suivantes ?

Var A, B : Entier
début

A ← 1

Algorithme

Prof.Fatima IBRAHIMI

B ← A + 3
A ← 3

Fin

Page 36

Exercice29

• Ecrire un algorithme qui demande un nombre , calcule et affiche la
somme

algorithme SommeCubique;
Var i, n, som: entier;

début
Ecrire(‘ Donnezn’);

Algorithme

Prof.Fatima IBRAHIMI

Ecrire(‘ Donnezn’);
Lire (n);
som← 0;

pour i=1 à n faire
som← som+i*i*i

finpour
Ecrire (‘ La somme cubiques des n entiers est :’,som);

fin

Page 37

Exercice30

• Donnez le résultat de la multiplication de deux nombres en ne
faisant que des additions.

algorithme multiplication;
Var a, b, i, res : Entier;

début

Algorithme

Prof.Fatima IBRAHIMI

Ecrire (" donnez les valeurs a et b" );
Lire(a); Lire(b);
res ← 0;

pour i de 1 à b faire
res ← res + a;

finpour
Ecrire (" la multiplication de a*b :" , res);

fin

Page 72

Exercice 54
• Donner un algorithme qui prend en argument un tableau d'entiers

de taille n et qui le modifie de tels sorts que tous les entiers pairs
se retrouvent avant les entiers impairs.

Algorithme

Prof.Fatima IBRAHIMI

Var i , n, j: Entiers
Tableau T (), Tres() :Entier
début

pour i de 0 à n – 1 faire
si T(i) MOD 2 ≠ 0 alors

Tres(j) ← T(i);

j ←0
pour i de 0 à n – 1 faire

si T(i) MOD 2 = 0 alors
Tres ( j )←T(i);
j ← j + 1;

finsi
finpour

j ← j + 1;

finsi
finpour
pour i de 0 à n – 1 faire

Ecrire ( Tres(i));
finpour
fin

Page 73

Exercice 54
• On dispose des notes de 25 élèves ; chaque élève peut avoir une ou

plusieurs notes mais toujours au moins une. Ecrire un programme
permettant d’obtenir la moyenne de chaque élève lorsqu’on lui
fournit les notes. On veut que les données et les résultats se
présentent ainsi :

Algorithme

Prof.Fatima IBRAHIMI

-Les parties italiques-Les parties italiques
correspondent aux données
tapées par l’utilisateur.

-La valeur -1 sert de critère
de fin de notes pour chaque

élève.

Similer Documents